SEB OB - Brand cards AIS major otage

Incident Report for Tink providers Denmark

Resolved

This incident has been resolved.
Posted Apr 06, 2025 - 08:30 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 06, 2025 - 05:28 UTC
This incident affected: SAS Eurobonus Mastercard.