Nordea OB - Major outage
Incident Report for Tink providers Denmark
Resolved
This incident has been resolved.
Posted Apr 27, 2024 - 04:05 UTC
Identified
We have identified the issue with account information and payment services. We are in contact with Nordea for further information.
We will update when a significant change to the situation occurs.
Posted Apr 26, 2024 - 19:44 UTC
This incident affected: Nordea.